(Un)HappyMacs – A Mac IIsi and Gooey Caps

My recent interest in Macintosh System 6 led me to acquire a new Mac for the HappyMacs lab – a System 6 capable Macintosh with a larger screen (14” or more) than the rather diminutive one available on the Mac SE that was, up until this time, the only machine in the lab running System 6.

Macintosh_IIsi

As I explained in my last post, I ultimately selected a Macintosh IIsi as my new “System 6 Engine” for the very pragmatic reasons that it was still relatively available on eBay, it did not cost the proverbial “arm and a leg” and it supported System 6 natively. Regrettably, I ran into trouble with this new acquisition almost immediately, and it took me more than just a little while to work through the universe of potential problems and zero in on what was actually going wrong.

Unhappy Mac - Color

As advertized, the machine arrived without a hard drive, but it did include a working floppy drive, and so it was immediately bootable. I have System 6 boot floppies from a separate purchase on eBay, and so I popped one in the floppy drive and powered up the machine for the first time. Unfortunately, it failed to boot (for reasons I did not understand at the time), and then to make matters worse, failed to eject the floppy. The mechanical floppy eject button did not do the job it was designed for, and I was reduced to gently prying the floppy out of the drive with a pair of needle-nosed pliers. This was not a good start!

I eventually did get the floppy out, and then worked through a succession of other sets of System 6 boot media until I finally experienced success… well, sort of. The machine finally did boot into one of the floppies I fed to it and presented a functioning System 6 desktop. Success! I thought… but only fleetingly. I quickly realized that the on-screen mouse pointer did not move when I moved the mouse. OK… lots of possible reasons for that… Bad mouse? Bad keyboard (the mouse was plugged into an ADB port on the keyboard, which was then plugged into the ADB port at the back of the IIsi)? Bad ADB cable? Bad system unit ADB port? Something else?

I slowly and methodically worked through all of the above, experiencing the occasional successful boot, only to be greeted by an inevitably “frozen” desktop in its aftermath. Eventually, I ruled out the mouse, the keyboard, the cable, the ADB port on the system unit, and even the monitor itself and was therefore left with only one possibility… something wrong with the system unit itself.

Mac IIsi Opened System Unit

That’s when I noticed “the goo”. Huh? …you are saying to yourself, “goo”? What in the world is “the goo”? Well, I am going to tell you! Anyone who enjoys the world of vintage Macintoshes has heard of the need to “recap” motherboards from time to time. This occasional necessity stems from the penchant of some aging motherboard capacitors (“caps”) to explode after many years of faithful service, severely compromising their intended function AND simultaneously spreading the electrolytic compound within them (the “goo”) all over their near vicinity on the motherboard.

Being aware of this, and starting to realize that the machine would never run for more than about a minute or so without freezing, no matter what I did (a behavior that sounded like a “cap” issue to me) I got out a flashlight and a magnifying glass and examined the motherboard in close detail. Sure enough, there was electrolytic “goo” on the motherboard in multiple locations. Sheesh! I had a “blown motherboard”! Below is a picture of one such site to give you a feeling for what this looks like.

Goo Site

I have bought no small number of vintage Macs on eBay and I have never received a bad one until now. I contacted the seller and he was very gracious about the whole thing. We agreed on a residual price for the re-usable parts in the machine and he refunded the difference. So, no damage had been done financially, BUT I had no “System 6 engine” either.

Recapping a motherboard is beyond both my capabilities and the facilities I have at hand, but I decided to try cleaning the goo off, hoping against reason that it was perhaps just shorting out some of the motherboard traces it was spread across. Such cleaning at least is easily done. All you need is some common rubbing alcohol and cotton swabs (such as Q-tips), both available at any local drug store (if not in your own medicine cabinet already!). Working slowly and carefully, I cleaned up all the goo sites I found. Below is a pic of a typical site I worked on:

Cleaning Goo

Eventually, I worked through a small bundle of Q-tips and was done. Would it work any better now? I powered it on, it booted up successfully… and it stayed booted! The mouse kept working and I was able to perform a successful shutdown for the first time ever. Thinking that I might have had the incredible good luck of dodging the “recap” bullet, I connected up the hard drive that was waiting to be added to the machine and powered it back on. This particular hard drive had a previously configured System 7 on it (to be replaced with System 6 as soon as possible, of course) and after a lengthy boot process, it presented its desktop and awaited my command.

I poked around in the control panels for a while, increasing the disk cache size and then enabling color for the display, and was honestly thinking to myself “well, this was too easy” when the mouse pointer froze once more! With a sinking heart, I tried again – no luck at all. No life at all. It would not boot. Here we go again…

To make a long story short, I discovered through trial and error that my motherboard cleaning efforts seem to have added about a minute or two to the system’s successful run time before it would again freeze. And freeze it would… and still does. Like clockwork, any session longer than two to three minutes results in a frozen machine. Unplug it and let it sit for about 4 hours and I can get another few minutes of run time out of it before it freezes again.

My conclusion? First, the motherboard definitely needs to be recapped, a roughly $125 undertaking when shipping in included. Second, the motherboard may not be the only issue. The power supply may also need to be recapped. I did not SEE any goo when I took it apart and examined it carefully, but that does not mean that there are not failed components in it. The time factor here (two the three minutes and then freeze) feels to me like how long it takes a damaged cap to either fully charge up or fully discharge – I am not sure which.

So, for now I have set this entire machine to the side and have purchased another one on eBay. It will be delivered shortly and I will try once again to establish a working System 6 test machine.

In the meantime, what can be learned from this experience of an unhappy Mac in the HappyMacs lab? Well I for one have learned to never again buy a Mac on eBay whose listing does not include pictures of the machine running its OS, and whose listing does not also include wording to the effect that it is fully operational. Otherwise, it is a case of caveat emptor (buyer beware)!

Advertisements