Sounds Like Trouble … And More Trouble

Sounds Like Trouble ... And More Trouble

What do you do when an Audio Visual (AV) computer like the Quadra 840AV looses its Audio? Sounds like trouble to me. Ever since I got my current Quadra 840AV on eBay, I have had trouble with erratic startups. Sometimes I get the startup chime and other times I do not, and the machine just sits there and will not boot (you can hear the hard drive spinning and the power supply fans running, but no boot). I suspect that the power supply is behind all of this, but I have not managed to find a replacement yet, and so when this happens, I just (im)patiently restart the machine repeatedly. Usually, after two or three restart attempts, the chime sounds and the machine boots. Annoying, but not mission critical.

So today, when I went to boot the Quadra 840AV and I did not get the start-up chime I was not worried. I applied my usual restart cure, but after 6 or so unsuccessful restart attempts I started to get worried. Since I suspect that a marginal power supply is behind all of this, I decided to just leave it running (but unbooted) for a time, to ensure that all the power supply and logic board capacitors were fully charged, which should reduce the current draw on the power supply somewhat on the next restart. Imagine my surprise then when 60s or so later, the Quadra suddenly sprang to life and started to boot. How could this be?

It IS worth noting that for both the Quadra 660AV and the Quadra 840AV, start up time is a function of the amount of RAM in the machine. At start-up, if you have not disabled this function, the machine runs a RAM test, the duration of which is pretty much directly proportional to the amount of RAM you have installed. In the case of the Quadra 840AV, I have maxed it out at 128MB, and so the start-up RAM test does take somewhere in the 30s to 60s range to complete. During this period of time, there is ZERO user feedback. You hear the start-up chime and then to all outward appearances, the machine just sits there doing nothing. At the end of the test, the monitor suddenly springs to life and the boot begins, but if you did not know better, you would assume that something was wrong with the machine.

In my case, I did NOT hear the start-up chime, and yet a minute or so later, the machine began its boot. Deducing that perhaps the speaker had failed (it had been making “popping” noises in the last day), and that is why I didn’t hear the chime, I restarted the machine. No chime, but again, after a disconcertingly long RAM test delay it booted and ran. I pulled up the Monitors and Sound control panel and tested the sound function – nothing. OK, so the speaker HAD probably failed. I plugged in a pair of external speakers. Still nothing. What am I to conclude? It definitely sounds like trouble to me … or rather it does not sound at all, which definitely IS trouble. I will have to dig into this and try to sort out what has happened. This IS how failures happen. All of a sudden, one day something just doesn’t work any more.

Meantime, as the title suggests, I have more trouble with sound on this machine… the power supply makes a fairly loud, high pitched and oscillating sort of noise that just burrows into my brain after a while and gives me a headache. I already suspected that the power supply needed help. Now I know for sure. At a minimum, I will need to extract it from the machine and rebuild it with a new, silent fan. I did this to my PowerMac 7500 and the result was glorious silence. You can barely tell that the machine is running. So, I am keeping my eye on eBay for a Quadra 840AV compatible power supply. When I find one, I will pick it up, strip it down, replace the fans and generally rebuild it. Hopefully something close to silence will reign supreme after it is installed into the Quadra.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s